Updating Site Builder on Server 3

Hello,Starting today we will be upgrading all versions of Site Builder for sites on server 3 to use Site Builder version 2.94. This upgrade is necessary because PHP is being updated as well and the older versions of Site Builder are experiencing issues with compatibility.¬†DUALCY APPIf your site was using the Dualsy mobile app, after the upgrade, ... Read More »

8th May 2017